Biblioteca PagSeguro SDK versão Legacy no PHP 7.1.23

Comentários

10 comentários

  • Rodrigo de Campos Ribeiro

    Nicolas, 

    Na lib antiga funciona PHP <=7.0 porém depende da versão.

    Da uma olhada no nosso git: https://github.com/pagseguro/pagseguro-php-sdk/tree/5.0.1

  • Nicolas Corbellini Leipnitz

    Entendo, mas não encontrei informações em quais versões específicas do PHP 7.0 lib antiga funcionaria.
    Meu stack tem a versão PHP 7.0.30.
    Você saberia me dizer se a lib antiga é compatível com essa versão específica do PHP?
    Ainda: alguns prejuízo de funcionamento por ser versão antiga da lib e não a mais atual?
    Valeu.

  • Nicolas Corbellini Leipnitz

    Melhor ainda, em quais versões do PHP 7.0.x , a antiga/legacy lib funciona?

    Eu não encontrei no branch do Git.

    Obrigado.

  • Nicolas Corbellini Leipnitz

    Rodrigo, no composer.json desta versão da lib que vc enviou [1] tem require ^5.6. Isso significaria que o PHP 7.0.30 funcionaria de boa, certo?

    [1] https://github.com/pagseguro/pagseguro-php-sdk/tree/5.0.1

  • Nicolas Corbellini Leipnitz

    Como fazer um git pull nessa versão específica 5.0.1 que exigiria PHP 5.6?
    Valeu.

  • Rodrigo de Campos Ribeiro

    Nicolas, 

    Não entendi muito bem essa pergunta:

    Como fazer um git pull nessa versão específica 5.0.1 que exigiria PHP 5.6? 

    Apenas vale lembrar que é uma versão da lib antiga.

  • Nicolas Corbellini Leipnitz

    Olá, Rodrigo.

    Você sabe dizer se essa versão é compatível com PHP 7.0.30?

  • Nicolas Corbellini Leipnitz

    Ou qual versão da Biblioteca PagSeguro é compatível com PHP 7.0.30?

  • Rodrigo de Campos Ribeiro

    Nicolas,

    Não existe um sdk compatível com essa versão, apenas com as versões que eu encaminhei. 

  • Nicolas Corbellini Leipnitz

    OK, valeu, cara!